Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 05, 2026 - 17:00 UTC
Scheduled
For Aug 5th
FortiGate Cloud 26.3 – Release Highlights
Provisioning and Deployment Enhancements -- ZTP to support pre-upgrade firmware when provisioning devices to FortiManager and FortiManager Cloud -- Provide device license status on the provisioning page
Firmware and Backup Management -- Consolidated firmware upgrade view -- Schedule a firmware upgrade to a target version without requiring knowledge of the device's current version -- Support for auto backup management across multiple devices
User Experience Enhancements -- OU selection GUI aligned with the Asset Management portal for a consistent experience -- Device list now shows how long each device has been online or offline -- Device list now displays the reason a device is blocked from log upload -- Customizable report email subject lines using placeholder variables for device number, report name, report type, and date
Expanded FortiOS Support -- Support for FortiOS v8.0.0 and FortiOS v7.6.7
Security Enhancements -- Security hardening across the FortiGate Cloud platform
Performance and Efficiency -- System-wide performance and efficiency improvements across the cloud service front end and backend
Service Impact: Impact FortiGate Cloud Global, EU, and US
Upgrade Time: For EU domain: 19:00 - 21:00 CEST For US domain: 19:00 - 21:00 EDT For Global domain: 17:00 - 19:00 PDT
Brief service interruptions may occur during the rollout. We aim to keep any disruption minimal, and thank you for your understanding
Posted Jul 30, 2026 - 01:01 UTC
This scheduled maintenance affected: FortiGate Cloud (Global, Europe, US).