Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2026 - 16:00 UTC
Scheduled
FortiGate Cloud 26.2 Upgrade
Release highlights:
User Experience Enhancements
-Enhanced multi-language support, now supporting French, Spanish, Portuguese, Traditional Chinese, Simplified Chinese, and Korean, in addition to English and Japanese.
-The Audit Log now records login and logout actions.
-Direct URL endpoint for FortiConverter menus for easy bookmarks.
-Device list performance enhancements.
-Users can now place a device on the map by address.
Simplified Folder-Based Management
-Support for folder scope permissions for CLI scripts.
-Support for folder scope permissions for Report templates.
-Support for folder scope permissions for Firmware profiles.
FortiConverter Enhancements
-Support for new vendors: Barracuda, Ivanti, and Untangle Firewall.
-UI update to enable multiple interface-type tabs for Cisco ASA tickets.
-FortiConverter information added to the Asset List and Dashboard.
-Restrict file upload formats to supported formats.
-Ticket emails now contain links to the ticket detail page. (1230849)
Upgrade Time: April 24th 9AM to 6 PM Pacific Time Service Impact: Impact FortiGate Cloud Global, EU, and US
Brief service interruptions may occur during the rollout. We aim to keep any disruption minimal, and thank you for your understanding.
Posted Apr 21, 2026 - 04:17 UTC
This scheduled maintenance affected: FortiGate Cloud (Global, Europe, US).